分析家公式网,指标公式,公式软件下载站 新网址www.70822.com.  |  分析家公式网登录 .
自用指标MADX(通达信公式 主图 源码 测试图)
  • 软件大小:6.00 KB
  • 推荐星级:
  • 更新时间:2021-01-13 00:16:31
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win10/Win9X/Win8/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:MADX  
  • (0)0%
    (0)0%

软件介绍

自用指标MADX(通达信公式 主图 源码 测试图)
 
 
MA1:MA(CLOSE,1);
MA5:MA(CLOSE,5);
IF(MA5>REF(MA5,1),MA5,DRAWNULL),COLORRED,LINETHICK5;
MA20:MA(CLOSE,20),LINETHICK2,COLORYELLOW;
UPPER:(1+11/100)*MA(CLOSE,10),COLORGREEN;
LOWER:(1-9/100)*MA(CLOSE,10),COLORGREEN;
ENE:(UPPER+LOWER)/2,COLORGREEN;
ZMA5:=MA(C,5);
BBMA10:=MA(C,10);
YC0X1:=ZMA5>=REF(ZMA5,1);
H02:=MAX(ZMA5,BBMA10);
L02:=MIN(ZMA5,BBMA10);
ZJPB2:=(C-REF(C,1))/REF(C,1)*100;
穿二线:=H02<C AND O<L02 AND YC0X1 AND ZMA5>REF(ZMA5,1) AND ZJPB2>3;
STICKLINE(穿二线,O,C,0.80,0),COLORBROWN;
角度10:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*57.3;
选股:=(角度10>=1 {现在是1度,角度可调} AND 穿二线);
STICKLINE(选股,O,C,1.180,0),COLOR0000FF;
STICKLINE(选股,O,C,0.50,0),COLOR00FFFF;
DRAWTEXT(选股,L*0.98, '穿二线'),COLORYELLOW;
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:=AAX3>3  AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
DRAWTEXT(VBA,H*1.05,'★卖'),COLORGREEN;
DRAWTEXT_FIX(1,0.980,20,1,'★分析家公式网'),COLORYELLOW;
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,L*0.97,'★买'),COLORRED;
STICKLINE(VB4,CLOSE,OPEN,2,0), COLORYELLOW ;
STICKLINE(VBA,CLOSE,OPEN,2,0),COLORCYAN  ;
MAC3:=(ATAN((MA(C,3)/REF(MA(C,3),1)-1)*100)*180/3.14115926);
M3:=MA(MAC3,3);
AA:=PLOYLINE(CROSS(MAC3,M3),M3);
AAB:=PLOYLINE(CROSS(M3,MAC3),MAC3);
买二:=COUNT(CROSS(MAC3,M3),AA<REF(AA,3) AND AAB>REF(AAB,3));
DRAWTEXT(买二,L*0.97,'★买二'),COLORMAGENTA;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(C,(REF(L,BH)+CZ*0.5),(REF(L,BH)+CZ*0.5),7,0),COLORAA00AA;
STICKLINE(C,REF(L,BH),REF(L,BH),5,0),COLOR2F73FF;
STICKLINE(ZT,REF(O,BH),REF(C,BH),5,0),COLORYELLOW;
DRAWTEXT(ZT,L*0.98,'★涨停'),COLOR4080FF;
VARZT:=BARSLAST(C/REF(C,1)>1.097);
STICKLINE(VARZT=2,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=2,L*0.95,'3天'),COLORFFFFFF;
STICKLINE(VARZT=4,H*1.03,H*1.02,1,0),COLOR666666;
DRAWTEXT(VARZT=4,H*1.06,'5天'),COLORFFFFFF;
STICKLINE(VARZT=7,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=7,L*0.95,'8天'),COLORFFFFFF;
STICKLINE(VARZT=12,H*1.03,H*1.02,1,0),COLOR666666;
DRAWTEXT(VARZT=12,H*1.06,'13天'),COLORFFFFFF;
STICKLINE(VARZT=20,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=20,L*0.95,'21天'),COLORFFFFFF;
STICKLINE(VARZT=33,H*1.03,H*1.02,1,0),COLOR666666;
DRAWTEXT(VARZT=33,H*1.06,'34天'),COLORFFFFFF;
STICKLINE(VARZT=54,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=54,L*0.95,'55天'),COLORFFFFFF;
STICKLINE(VARZT=88,H*1.03,H*1.02,1,0),COLOR666666;
DRAWTEXT(VARZT=88,H*1.06,'89天'),COLORFFFFFF;
STICKLINE(VARZT=143,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=143,L*0.95,'144天'),COLORFFFFFF;
STICKLINE(VARZT=232 ,H*1.03,H*1.02,1,0),COLOR666666;
DRAWTEXT(VARZT=232,H*1.06,'233天'),COLORFFFFFF;
STICKLINE(VARZT=376,L*0.97,L*0.98,1,0),COLOR666666;
DRAWTEXT(VARZT=376,L*0.95,'377天'),COLOR666666;
 
N:=120;
KK:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,KK),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,KK),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
{三直线}
STICKLINE(CURRBARSCOUNT=N,GD,DD,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;
高区:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,高区*0.99,'  高区'),COLORRED;
低区:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLOR00FF00,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,低区,'  低区'),COLORRED;
平衡:IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF;
{DRAWTEXT(CURRBARSCOUNT=1,平衡,'  平衡'),COLORGREEN;}
低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
支撑:=IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'  支撑'),COLOR00FFFF;
STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0),COLORFF00FF;
强势:=IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
DRAWTEXT(CURRBARSCOUNT=1,强势,'  强势'),COLORGREEN;
突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=1,突破,'  突破'),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N,强势,强势,2,0),COLORFF00FF;
警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,警示,'  警示'),COLORGREEN;
压力:=IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=1,压力,'  压力'),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0),COLOR00FFFF;
低涨:=IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,KK)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
顶点:IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT;
STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;
低点:IF(CURRBARSCOUNT<=N, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT;
STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;
{DRAWBAND(高区,RGB(120,20,0),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(80,0,100),低区,RGB(0,0,0));
DRAWBAND(高,RGB(100,100,0),压力,RGB(0,0,0));}
DRAWTEXT(CURRBARSCOUNT=N/4+8,GD-KJ*0.09,'【风险区】--高抛避险'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+10,GD-KJ*0.4,'【拉升区】--强势畜锐'),COLORFFFF80;
DRAWTEXT(CURRBARSCOUNT=N/4+15,DD+KJ/3,'【关注区】--逢低买入'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+20,DD+KJ/10,'【低吸区】--大胆买入'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=N/2+10,GD-KJ*0.25,'【拉升区】'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=N/2+10,DD+KJ*0.25,'【持股区】'),COLORYELLOW;

下载地址(点击下图进入下载地址网页)

    自用指标MADX(通达信公式 主图 源码 测试图)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信金融终端版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

分析家公式网声明:本站所有股票公式、股票软件、股票书籍均免费。站内所有广告,如有收费行为,均与本站无关!请网友小心谨慎。
Copyright © 2003-2008 70822.Com. All Rights Reserved .
页面执行时间:4,500.00000 毫秒