分析家公式网,股票公式,股票软件下载站用户登录  |  用户 注册
MACD三背离(通达信公式 副图 源码 测试图)
  • 软件大小:4.00 KB
  • 推荐星级:
  • 更新时间:2022-01-15 00:15:29
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win10/Win9X/Win8/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:MACD三背离  
  • (0)0%
    (0)0%

软件介绍

 {MACD三背离}

 
日周期:=PERIOD=5;
MD周:=IF(日周期,MACD.DEA#WEEK,DRAWNULL);
MD周_:=IF(MD周>REF(MD周,5) AND 日周期,MACD.DEA#WEEK,DRAWNULL);
SHORT:=12;
LONG:=26;
MID:=9;
DIF1:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA1:=EMA(DIF1,MID);
MACD1:=(DIF1-DEA1)*2;
MH:=MACD1;
HHM:=CONST(HHV(MACD1,240));
MM:=0.3*HHM;
DIF:DIF1,COLORGREEN;
DEA:DEA1,COLORWHITE;
DIF升:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORMAGENTA;
DEA升:IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIRED;
MACD:MACD1,COLORSTICK,COLORYELLOW;
金叉:=CROSS(DIF,DEA);
轴上金叉:=金叉 AND DEA>0;
轴上周期:=BARSLAST(CROSS(0,DEA));
轴上金叉数:=COUNT(轴上金叉,轴上周期);
二次金叉:=轴上金叉 AND 轴上金叉数=2;
TDXSTEP121:DRAWICON(二次金叉,0.8*DEA,1);
TDXSTEP122:DRAWICON(二次金叉,0.7*DEA,1);
A1:=BARSLAST(REF(CROSS(DIF,DEA) AND DIF<0,1));
HC:=HHV(CLOSE,6);
B1:=REF(HC,A1+1)>HC AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA) AND DIF<0 AND A1>=12;
K:=KDJ.K(9,3,3);
D:=KDJ.D(9,3,3);
R1:=RSI.RSI1(6,12,24);
R2:=RSI.RSI2(6,12,24);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(CLOSE,A2+1)>CLOSE AND REF(K,A2+1)<K AND CROSS(K,D) AND A2>=9;
A3:=BARSLAST(REF(CROSS(R1,R2),1));
B3:=REF(CLOSE,A3+1)>CLOSE AND REF(R1,A3+1)<R1 AND CROSS(R1,R2) AND A3>=6;
C1:=BARSLAST(REF(CROSS(DEA,DIF) AND DIF>0,1));
LC:=LLV(CLOSE,6);
D1:=REF(LC,C1+1)<LC AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF) AND DIF>0 AND C1>=12;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(CLOSE,C2+1)<CLOSE AND REF(K,C2+1)>K AND CROSS(D,K) AND C2>=9;
C3:=BARSLAST(REF(CROSS(R2,R1),1));
D3:=REF(CLOSE,C3+1)<CLOSE AND REF(R1,C3+1)>R1 AND CROSS(R2,R1) AND C3>=6;
M底背:IF(B1>0,1,0),NODRAW,COLORRED;
K底背:IF(B2>0,1,0),NODRAW,COLORMAGENTA;
R底背:IF(B3>0,1,0),NODRAW,COLORYELLOW;
M顶背:IF(D1>0,1,0),NODRAW,COLORGREEN;
K顶背:IF(D2>0,1,0),NODRAW,COLORFFCC66;
R顶背:IF(D3>0,1,0),NODRAW,COLORGRAY;
TDXSTEP123:STICKLINE(M底背,-MM,0,1,0),COLORRED;
TDXSTEP124:STICKLINE(K底背,-MM,0,1,0),COLORMAGENTA;
TDXSTEP125:STICKLINE(R底背,-MM,0,1,0),COLORYELLOW;
TDXSTEP126:STICKLINE(M顶背,MM,0,2,0),COLORGREEN;
TDXSTEP127:STICKLINE(K顶背,MM,0,2,0),COLORFFCC66;
TDXSTEP128:STICKLINE(R顶背,MM,0,2,0),COLORGRAY;
TDXSTEP129:STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLOR00CCFF;
TDXSTEP130:STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORRED;
TDXSTEP131:STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORFF5599;
TDXSTEP132:STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORFFFF55;
J:KDJ.J,NODRAW;
RSI:R1,NODRAW,COLORMAGENTA;
CCI:CCI,NODRAW;
 

下载地址


软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击“本地高速下载”,打开新页面,如扣分0分,点击:立即下载。如扣分不是0,请注册并充分值后再点:立即下载

* 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载

本网提供的公式文件说明:
/span> * alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信金融终端版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称,并且能正常显示,可能是公式使用期限已过。
* 关于还原公式源码如果你忘记了自己编写的大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等公式的密码,本网可帮恢复源码,完全加密定向加密均可,收fei服务无意勿扰,点击右侧在线咨询联系我。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含源码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

分析家公式网声明:本站所有股票公式软件资料均网上公开收集,如侵权请联系删帖。站内所有广告,均与本站无关!
Copyright © 2003-2008 70822.Com. All Rights Reserved .
页面执行时间:2,295.89800 毫秒