分析家公式网,指标公式,公式软件下载站 新网址www.70822.com.  |  分析家公式网登录 .
MACD短线分析结合价量分析(通达信公式 副图 源码 测试图)
  • 软件大小:7.00 KB
  • 推荐星级:
  • 更新时间:2021-06-11 07:05:57
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win10/Win9X/Win8/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:MACD短线分析  MACD加量能分析提示  
  • (0)0%
    (0)0%

软件介绍

 MACD加量能分析提示

系统公式MACD是最常用的指标,一点也不过分,
但是macd这个公式,有一个去电,就是滞后,性就是说金叉买点滞后(这也罢有利于所谓的右侧交易),但死叉卖点滞后其后果就严重了!
本指标含有量能分析提示,并且优化了金叉死叉参数,基本上与K线趋势相同了,你们可以自己划线对比去。
还是不错的


 
{MACD短线分析}
DIF:EMA(CLOSE,7) - EMA(CLOSE,19),COLORFF9900,NODRAW;
DEA:EMA(DIF,9),COLORBROWN,NODRAW;
DRAWBAND(DEA,RGB(0,0,80),DIF,RGB(90,0,0));
MACD:(DIF-DEA)*2,COLORSTICK,COLOR0000FF;
 
VAR3:=HHV(HIGH,60);
VAR4:=LLV(LOW,30);
VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR6:=(VAR3+VAR4+VAR5)/3;
VAR7:=EMA(VAR6,5);
K:=EMA(VAR7,5)*2, COLORFF00FF;
D:=EMA(K,5), COLORWHITE;
J:=K*3-D*2, COLORYELLOW;
ENTERLONG:=CROSS(K,D);
EXITLONG:=CROSS(D,K);
{NOTEXT强:IF(DIF>MA(DIF,2),DIF,DRAWNULL),COLORRED,LINETHICK2;}
 
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=-L2_AMO(0,3)/10000.0;
大S:=-L2_AMO(1,3)/10000.0;
中S:=-L2_AMO(2,3)/10000.0;
小S:=-L2_AMO(3,3)/10000.0;
资金净流入万:(超B+大B+中B+小B)+(超S+大S+中S+小S),NODRAW,COLORWHITE;
TJ1:=(C+0.01-REF(C,1))/REF(C,1)*100;
TJ2:=(C-0.01-REF(C,1))/REF(C,1)*100;
TJ3:=(C-REF(C,1))/REF(C,1)*100;
Q1:=IF(TJ1>10.05,1,0);
Q2:=IF(TJ2<9.95 AND TJ3>=9.95,1,0);
{涨停板:IF(Q1 OR Q2,0.5,0),COLORFF00FF;}
涨停板:STICKLINE(IF(Q1 OR Q2,1,0),MACD,0,1,0),COLORFF00FF;
TT:=240/FROMOPEN;
比:=TT;
促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));DRAWTEXT_FIX(C>O,0.01,0.01,0,' 分析家公式网WWW.70822.COM'),COLORFF8000;
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YYAVX > 0,200,100));
J2:=CONST(IF( YYAVX > 0,00,100));
J3:=CONST(IF( YYAVX > 0,100,100));
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
MFI:=(HIGH-LOW)*1000000/(VOL*比);
TS1:=IF(情况1=1,0.7+0.06,0.7);
TS2:=IF(情况2=1,TS1+0.06,TS1);
TS3:=IF(情况3=1,TS2+0.06,TS2);
TS4:=IF(情况4=1,TS3+0.06,TS3);
TS5:=IF(情况5=1,TS4+0.06,TS4);
TS6:=IF(情况6=1,TS5+0.06,TS5);
TS7:=IF(情况7=1,TS6+0.06,TS6);
TS8:=IF(情况8=1,TS7+0.06,TS7);
TS9:=IF(情况9=1,TS8+0.06,TS8);
TS10:=IF(情况10=1,TS9+0.06,TS9);
TS11:=IF(情况11=1,TS10+0.06,TS10);
TS12:=IF(情况12=1,TS11+0.06,TS11);
TS13:=IF(情况13=1,TS12+0.06,TS12);
TS14:=IF(情况14=1,TS13+0.06,TS13);
TS15:=IF(情况15=1,TS14+0.06,TS14);
TS16:=IF(情况16=1,TS15+0.06,TS15);
TS17:=IF(大盘1=1,TS16+0.06,TS16);
TS18:=IF(大盘2=1,TS17+0.06,TS17);
TS19:=IF(大盘3=1,TS18+0.06,TS18);
TS20:=IF(大盘4=1,TS19+0.06,TS19);
TS21:=IF(大盘5=1,TS20+0.06,TS20);
TS22:=IF(大盘6=1,TS21+0.06,TS21);
TS23:=IF(大盘7=1,TS22+0.06,TS22);
TS24:=IF(大盘8=1,TS23+0.06,TS23);
DRAWTEXT_FIX(情况1=1 ,0,0.00,0,'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORCYAN;
DRAWTEXT_FIX(情况2=1 ,0,0.00,0,'走势趋强量能不足,短线进场,仓位在1/2左右'),COLORCYAN;
DRAWTEXT_FIX(情况3=1 ,0,0.00,0,'量价良好,并没有明显走强,短线进场,仓位1/2左右。'),COLORCYAN;
DRAWTEXT_FIX(情况4=1 ,0,0.00,0,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORCYAN;
DRAWTEXT_FIX(情况5=1 ,0,0.00,0,'形态变坏,走势尚可,重仓减大半,清仓者观望。'),COLORCYAN;
DRAWTEXT_FIX(情况6=1 ,0,0.00,0,'随大盘一起下跌,明显缩量走势,考虑大盘风险,减持或清仓。'),COLORCYAN;
DRAWTEXT_FIX(情况7=1 ,0,0.00,0,'该股放量下跌,走势明显偏弱,离场观望。'),COLORCYAN;
DRAWTEXT_FIX(情况8=1 ,0,0.00,0,'该股缩量下跌,走势偏弱,离场观望。'),COLORCYAN;
DRAWTEXT_FIX(情况9=1 ,0,0.00,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLORCYAN;
DRAWTEXT_FIX(情况10=1,0,0.00,0,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险'),COLORCYAN;
DRAWTEXT_FIX(情况11=1,0,0.00,0,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORCYAN;
DRAWTEXT_FIX(情况12=1,0,0.00,0,'该股走势趋弱,量能不足,减持大部分筹码'),COLORCYAN;
DRAWTEXT_FIX(情况13=1,0,0.00,0,'该股形态不佳,注意成交量的变化,但目前不适合参与。'),COLORCYAN;
DRAWTEXT_FIX(情况14=1,0,0.00,0,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORCYAN;
DRAWTEXT_FIX(情况15=1,0,0.00,0,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORCYAN;
DRAWTEXT_FIX(情况16=1,0,0.00,0,'该股走势太弱,没有参与价值。'),COLORCYAN;
DRAWTEXT_FIX(大盘1,0,0.13,0,'总势量能理想,2/3仓位, 前一轮下跌,是否最佳买点,否则谨慎介入。'),COLORCYAN;
DRAWTEXT_FIX(大盘2,0,0.13,0,'总势趋强,量能不足,若前一轮下跌,短线进场1/2,量能放大加仓。'),COLORCYAN;
DRAWTEXT_FIX(大盘3,0,0.13,0,'总势形态走坏,重仓者可以减去大部分仓位。'),COLORCYAN;
DRAWTEXT_FIX(大盘4,0,0.13,0,'总势缩量调整,注意风险,短线清仓观望。'),COLORCYAN;
DRAWTEXT_FIX(大盘5,0,0.13,0,'总势走势良好,量能理想,可以继续持有强势股。'),COLORCYAN;
DRAWTEXT_FIX(大盘6,0,0.13,0,'总势形态良好,但量能稍显不足,随时准备减仓'),COLORCYAN;
DRAWTEXT_FIX(大盘7,0,0.13,0,'总势趋势不明,注意成交量变化,目前不适宜进场。'),COLORCYAN;
DRAWTEXT_FIX(大盘8,0,0.13,0,'总势趋势向下,量能萎缩,不适合进场。'),COLORCYAN;
 
NOTEXTDIF:DIF,COLORFF9900,LINETHICK1;
NOTEXTDEAF:DEA,COLORBROWN;
NOTEXT强:IF(DIF>MA(DIF,2),DIF,DRAWNULL),COLORRED,LINETHICK2;
 
通达信公式

下载地址(点击下图进入下载地址网页)


软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信金融终端版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

分析家公式网声明:本站所有股票公式软件资料均网上公开收集,如侵权请联系删帖。站内所有广告,均与本站无关!
Copyright © 2003-2008 70822.Com. All Rights Reserved .
页面执行时间:1,476.56300 毫秒