分析家公式网,免费股票公式,股票软件下载站 用户登录  |  用户 注册
macd结构副图,钝化、结构形成、消失一目了然(飞狐公式 副图 源码 测试图)
  • 软件大小:0 Bytes
  • 推荐星级:
  • 更新时间:2020-03-31 06:38:33
  • 软件类别: 国产软件 / 飞狐公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:股票公式 股票软件
  • (0)0%
    (0)0%

软件介绍

这个macd结构副图公式,还可以,就不用徐小明的定量结构了。

钝化、结构形成、消失一目了然。
另外加上了RIS指标。好不好用,你自己看。

适用于飞狐软件,不是通达信公式。


DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT;
DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT;
MACD:(DIF-DEA)*2,Precision2,LINETHICK0;
{MACD底部结构预警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
{DRAWTEXT(死叉,DIF*1.05,'↓M死'),COLORF0DC97;}
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1); 
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),LINETHICK0;
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,3,0),ColorYellow;{柱线带}
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'形成'),colormagenta;
DRAWTEXT(FILTER(底背离消失,10),MACD*1.1,'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA)*0.6,4,0), ColorRED;{柱线}
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
DRAWTEXT(金叉,DIF*1.05,'↑M金'),COLORRED;
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA)*0.6,3,0), COLORE79A32;{柱线}
STICKLINE(T OR TG,DIF,DEA,5,0),colorgreen;{柱线带}
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'形成'),colormagenta;
DRAWTEXT(FILTER(顶背离消失,20),MACD*1.2,'消失'),colorgreen;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
 DRAWTEXT(二次翻红,MACD*1.5,'←复红'),COLORFF80FF;
{分析家公式网 www.70822.com}
LC:= REF(C,1);
RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100,LINETHICK0,Precision1;
RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,LINETHICK0,Precision1;
RSI3:=SMA(MAX(C-LC,0),24,1)/SMA(ABS(C-LC),24,1)*100,LINETHICK0,Precision1;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2),ColorWhite;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
RSI底背:=B3>0;
DRAWTEXT(B3>0,dif*1.05,'  R底背'),COLORred;{DRAWICON(B3>0,macd*1.2,1);{FILTER(B3>0,3),nodraw;
RSI顶背:=D3>0;DRAWTEXT(D3>0,dif*1.1,'R顶背'),ColorGreen;
 
STICKLINE(MACD>0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORRED;
STICKLINE(MACD>0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORYELLOW;
STICKLINE(MACD<0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORMAGENTA;
STICKLINE(MACD<0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORGREEN;

下载地址(点击下图进入下载地址网页)

    macd结构副图,钝化、结构形成、消失一目了然(飞狐公式 副图 源码 测试图)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信金融终端版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ984388831。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有股票软件、股票书籍和股票新闻均免费。站内所有广告,如有收费行为,均与本站无任何关系!请网友小心谨慎。
Copyright © 2003-2008 70822.Com. All Rights Reserved .
页面执行时间:1,875.00000 毫秒